Loss of Power

Click here if this is your business
★★★★★
4.6 / 5
84% of users recommend this
Click here if this is your business
  • Performance

  • Practicality

  • Reliability

  • Value For Money

piphardy's review of Toyota Land Cruiser Amazon 4.2 TD

★★★★☆

“Loss of Power”

Written on: 03/04/2013 by piphardy (1 review written)

Can somebody please help. My Land Cruiser is 10 years old and I love it. A problem I have at the moment is , I can be driving along and suddenly the engine management light appears and I lose power to the poiny where my car will only travel at around 20mph with very little revs. I stop, turn the ignition key off, turn the ignition key on and the management light goes off and I am back to full power,
If anyone has experienced this I would be glad to hear from you. Thank you.

If you are commenting on behalf of the company that has been reviewed, please consider upgrading to Official Business Response for higher impact replies.

Jedstacky's Response to piphardy's Review

Written on: 19/07/2013

hi same problem, local garage says turbo carbond up cleaned it much better but not perfect recomend giving it more wellie. !turbo not responding when needed basicly

Reply to this comment
If you are commenting on behalf of the company that has been reviewed, please consider upgrading to Official Business Response for higher impact replies.

Peteryap's Response to piphardy's Review

Written on: 16/03/2014

Please check your valve sensor. Once change, it goes back to the iriginal power instead of 30% of the original power. The ither thing is, at lost if power, dud you slowly increase the throttle to move faster and suddenly drops back to 20mph? If this is the case, most likely it'll be from the valve sensor.

Reply to this comment
If you are commenting on behalf of the company that has been reviewed, please consider upgrading to Official Business Response for higher impact replies.
Report this review